Nethunter apt issue resolving http.kali.org

Been a while since I fired up my Nethunter tablet, its such a great form factor, small and portable. It has not been used in anger yet, but I do like to keep all my devices updated. Especially with the latest versions of exploit-db fresh from the Kali repo’s ūüôā

Unfortunately that task failed. :-/

Issue: Apt fails to resolve http.kali.org, error below.

root@kali:~# apt-get update
Err:1 http://http.kali.org/kali kali-rolling InRelease
Temporary failure resolving 'http.kali.org'
Reading package lists... Done
W: Failed to fetch http://http.kali.org/kali/dists/kali-rolling/InRelease Temporary failure resolving 'http.kali.org'
W: Some index files failed to download. They have been ignored, or old ones used instead.

The standard checks of /etc/resolv.conf to see if I was missing any DNS servers. Then the /etc/hosts file also in case anything weird was stopping the resolver from trying DNS. All looked normal.

Other things such as dig and apps such as Firefox were behaving normally. This meant it was not a networking issue or a real resolver issue system wise. It was unique to apt.

Solution:

A web search provided the following check and fix.

grep 'apt' /etc/passwd|
_apt:x:114:65534::/nonexistent:/bin/false

Update the ‘_apt’ UID to 0

_apt:x:0:65534::/nonexistent:/bin/false

/etc/passwd format:
username:password:UID:GID:user info:Home dir:command shell

Related Bug: apt-get errors

Explanation (sort of): seems like the user _apt had issues using the resolver, update the UID and things worked fine. No real explanation in the bug report other than it was fixed in later releases.

Note: The permission on /etc/resolv.conf were set to -rw—— but updating these so users could read the file did not fix this. So the original fix above still stands.

Hope this helps someone.

 

edb Failed to load missing core debugger plugins

Hit an issue with starting the Linux debugger: edb when trying a buffer overflow exercise in Kali a little time after I updated it. Been a little while since I did an exercise of this nature so am not sure how long this has remained broken.

EDB will not run and just displays a blank screen with the message displayed below.

edb_error1

I did manage to fix this after doing a search of the file system to locate the relevant plugins/libs necessary (locate edb |grep  libDebuggerCore.so )

Solution: Options > Preferences > > Plugin Directories

This value in my case should of read /usr/lib/x86_64-linux-gnu/edb or what ever the above command found, not every system is the same.

Update and close, then restart edb.

There was a bug reference about this dated Feb 2017. Github Bug edb New packages were updated but the user pref in your home directory (.config/codef00.com/edb.conf) may still have the old ref in it and not work despite having the correct package version. The fix above updates this file.

Hope this helps someone.

Kali / Linux ESXi Resolution resize issue.

Issue: Changing the desktop resolution on Linux or in my case Kali has issues in ESXi. It either fails, goes blank or displays corrupted image until it reverts itself back to 800×600.

I stumbled upon this with a new installation in a testing network I was playing with, despite installing vmtools on the client and updating them numerous times I could not get the desktop to a more usable resolution over 800×600. Was it drivers for the video card, monitor? Well after 30 mins of googling I found a solution¬†in the Kali forums (Thanks to SpeedyQuick.)

Solution:

Increase video card memory in vSphere Client to 32MB from the default of 4MB. Then you should be able to resize to your desired resolution.

vmware_display_mem

I’d imagine if you were having similar issues with Virtualbox this solution would also apply, one thing to note though is that Virtualbox seems to default to a higher amount so I have not seen this issue yet.